Update von Group-Office 5 auf Version 6.1.x meistern

Am Wochenende habe ich mich erneut mit dem Update von Group-Office 5 auf die aktuelle Version 6.1.x beschäftigt. Normalerweise klappt die Aktualisierung recht unkompliziert. Aber bei größeren Versionssprüngen kann der Fehlerteufel schon mal zuschlagen. So auch in diesem Fall. Seit Version 6 zeigt Group-Office den verwendeten Speicherplatz im Datei-Modul an und bietet Administratoren die Möglichkeit jedem Nutzer ein Speicherkontingent zuzuweisen. Feine Sache. Das kenne ich bereits von ownCloud. Ich hatte nach dem Group-Office Update das Phänomen, dass der belegte Speicher nur bei einem Nutzer berechnet wurde. Bei allen anderen Usern war dem nicht so. Warum? Gute Frage. Ich habe lange damit herumexperimentiert, kann mir den Fehler jedoch nicht erklären.

Speicherverwaltung in Group-Office 6.1.x
Speicherverwaltung in Group-Office 6.1.x

Mit einer frischen Installation und dem alten Datenbestand trat genau der gleiche Fehler auf. Lud ich neue Dateien hoch, wurden sie vom System auch erfasst. Wie löst man dieses Problem? Hier mein Lösungsvorschlag. Im Grunde ganz simpel. Man ermittelt zunächst den belegten Speicherplatz eines jeden Group-Office Nutzers in Byte. Anschließend nimmt man eine kleine Anpassung in der Datenbank vor. In der Tabelle go_users wird der Speicherplatz vermerkt. Den Wert disk_usage ändert man einfach auf die ermittelten Byte-Werte. Im Group-Office führt man danach eine Überprüfung der Datenbank, Neugenerierung des Suchindexes und Synchronisierung zwischen Dateisystem und Datei-Modul durch. Danach sollten die Werte über einen gewissen Zeitraum beobachtet werden, ob sie sich korrekt verhalten. Bei meinen Tests war dies der Fall.

disk_usage in der Datenbank manuell anpassen
disk_usage in der Datenbank manuell anpassen

Ich habe nacheinander die alten Daten gelöscht, modifiziert und erneut hochgeladen. Die Speicheranzeige verhielt sich dabei vollkommen korrekt. Warum man den Startwert in diesem Fall vorgeben muss, ist mir schleierhaft. Wahrscheinlich betrifft das Phänomen nicht mal alle Installationen, sondern nur einige. Es wäre möglich, dass dieses Problem relativ speziell ist. Wer genauso an dieser harten Nuss knabbert, findet hier eine zielführende Lösung.


Avatar von reraiseace
Autor: Markus Werner (reraiseace) Twitterreraiseace, Google+reraiseace, Twittercb_werner
Ich bin Redaktionsvolontär bei der COMPUTER BILD in Hamburg, Fernstudent am Deutschen Journalistenkolleg und schreibe auf re{raise}ace privat über Webdesign und Programmierung. Seit 2015 schrieb ich auch regelmäßig für andere Medien.

0 Kommentare

Du kannst diesen Artikel nicht mehr kommentieren.