Huawei Ascend P1 rooten und Custom Recovery flashen

Seit einigen Wochen bin ich stolzer Besitzer des Huawei Ascend P1. In meinem Testbericht könnt ihr euch einen genaueren Eindruck von Huaweis Galaxy S2 Konkurrenten verschaffen. Bei fast jedem Android-Gerät kommt irgendwann die Frage: Wie roote ich es? Na ja, im Grunde ist es beim Ascend P1 relativ einfach. Aber wenn man nicht genau weiß, was man tun soll, wirds etwas schwierig. Daher möchte ich euch ein kleines und leicht verständliches Howto bieten. Zusätzlich erkläre ich ebenfalls, wie ihr ein Custom Recovery flashen könnt. Meine Ausgangsversion ist die Firmware B315. Es funktioniert aber auch mit vielen anderen Versionen. Solltet ihr Probleme haben, dann schaut in den Huawei Ascend P1 Bereich auf Android-Hilfe.

Root-Zugriff leicht gemacht — ADB, Fastboot und TWRP

Um euer P1 rooten zu können benötigt ihr ein funktionierendes Windows, eine installierte HiSuite samt lauffähigen Treibern für das Ascend P1. Ladet euch zunächst die Universal ADB Driver von CWM-Entwickler Koushik Dutta herunter und installiert diese anschließend (im Idealfall unter C:\ADB. Nun braucht ihr noch die RootU9200.zip. Entpackt alles in den Ordner, wo ihr die ADB Treiber installiert habt. Startet nun unter Windows die Eingabeaufforderung mit Administrator-Rechten. Wechselt in das Verzeichnis von ADB.

cd C:\ADB

Schließt jetzt euer P1 im HiSuite-Modus an. Kopiert die SuperSU-Busybox-Installer.zip auf den internen Speicher oder die microSD-Karte. Stellt sicher, dass die HiSuite installiert, aber nicht gestartet ist und euer P1 vom PC korrekt erkannt wird. In die Kommandozeile am PC tippt ihr nun folgenden Befehl ein und versetzt das Smartphone in den Fastboot-Modus.

adb reboot bootloader

Wenn ihr das Huawei Logo seht, öffnet am Computer “Geräte und Drucker”. Sucht dort nach dem Gerät “Blaze”. Sollte es mit einem Warndreieck versehen sein, dann geht über das Kontext-Menü auf “Eigenschaften”, wechselt zum Reiter “Hardware” und klickt auf den einzigen existierenden Eintrag. Anschließend auf “Treiber aktualisieren” und wählt aus der Liste “Android Sooner Single ADB Interface” aus. Danach sollte das Ascend P1 am PC erkannt werden. Zur Veranschaulichung habe ich euch einen Screenshot angefertigt.

den richtigen Treiber für "Blaze" installieren
den richtigen Treiber für “Blaze” installieren

Tippt anschließend den nachstehenden Befehl ein. Damit startet ihr das Gerät in das temporäre Custom Recovery. Es wird nicht geflashed. Sprich: Nach dem Neustart ist es wieder weg.

fastboot boot TWRP.img

Wartet ein bisschen und auf eurem P1 sollte nach wenigen Sekunden TWRP geladen werden. Nun geht es am Smartphone weiter. Geht auf “Install”, sucht euch die SuperSU-Busybox-Installer.zip heraus und installiert sie. Abschließend geht ihr zurück ins Hauptmenü, danach auf “Reboot” und tippt auf “System”. Ihr werdet daraufhin gefragt, ob ihr “Permission fix” ausführen wollt. Bestätigt dies einfach. Nach dem euer P1 neu gestartet wurde, ist es schon gerootet. Möchte man den Root-Zugriff wieder entfernen, klappt das über SuperSU oder indem ihr die Firmware neu flashed. Linux-Nutzer finden bei Android-Hilfe die passende Anleitung.

Custom Recovery flashen ist simpler als es aussieht

Das Flashen eines anderen Recovery ist nicht sonderlich schwer. Ich rate euch dazu, vorher ein Backup eurer Stock Recovery anzulegen. Hierzu nehmt ihr CWM. Startet es genauso, wie TWRP. Ruft aber nicht die “TWRP.img” auf, sondern “cwm_viva_beta.img”. Erstellt ein vollständiges Backup. Die “recovery.img” könnt ihr euch danach herauskopieren. Wenn ihr damit fertig seid, bringt das P1 wieder in den Fastboot-Modus. Die Befehle schauen nun wie folgt aus. Prüft aber vor den Fastboot-Kommandos nochmals, das “Blaze” korrekt installiert wurde. Benennt das Recovery, welches ihr flashen möchtet, in “recovery.img” um. Stellt sicher, dass sich die Fastboot.exe und die IMG-Datei im selben Ordner befinden.

adb reboot bootloader
fastboot devices
fastboot flash recovery recovery.img
fastboot reboot

Erscheint bei fastboot devices kein Gerät, überprüft abermals die Verbindung. Die Eingabeaufforderung muss als Administrator ausgeführt werden. Wenn alles geklappt hat, dann sollte CWM oder TWRP drauf sein. Je nachdem, welches ihr ausgewählt habt. Um das Stock Recovery oder ein anderes zu flashen, geht ihr genauso vor, wie oben beschrieben. In der RootU9200.zip habe ich euch vier verschiedene Recoverys zur Verfügung gestellt: TWRP 2.4.4.0, CWM 6.0.1.9, CWM Touch Recovery Viva Beta und das Stock Recovery der B315. Das Stock Recovery wird benötigt, um eine Firmware via Dload-Methode zu flashen und den Auslieferungszustand wiederherzustellen.

Update 04.12.2013 – 07:50: roscoe hat mich in den Kommentaren darauf aufmerksam gemacht, dass sich SuperSU bei ihm nicht installieren lässt. Als er jedoch aus /system/app/ einige Anwendungen löschte, funktionierte das Aufspielen sofort. Dieses Problem tritt allerdings nicht bei allen P1-Geräten auf, daher solltet ihr nur dann einige Apps löschen, wenn SuperSU nicht installierbar ist. Im TWRP mountet ihr die System-Partition (Mount ⇒ Mount System) und über den TWRP-Dateimanager löscht ihr überflüssige Bloatware (Advanced ⇒ File Manager).

Warnung Sollte doch etwas schief gehen, übernehme ich keine Haftung. Ihr tragt das Risiko ganz alleine! Beachtet bitte, dass eventuell die Garantie durch diese Aktion erlöschen kann.


Avatar von reraiseace
Autor: Markus Werner (reraiseace) Twitterreraiseace, Google+reraiseace, Twittercb_werner
Ich bin Redaktionsvolontär bei der COMPUTER BILD in Hamburg, Fernstudent am Deutschen Journalistenkolleg und schreibe auf re{raise}ace privat über Webdesign und Programmierung. Seit 2015 schrieb ich auch regelmäßig für andere Medien.

62 Kommentare

Du kannst diesen Artikel nicht mehr kommentieren.

  1. Kommentar von Tobias We · · #

    danke :D hat mir echt weitergeholfen :) ich hab da nur eine frage, ob du/sie mir vielleicht helfen könnten, cyanogenmod zu installieren, weil ich in dieser scene relativ neu bin :D
    danke im vorraus und natürlich danke für dieses tutorial :)

    liebe grüße Tobias We

  2. Kommentar von reraiseace · · #

    Bitte, bitte. Das “Du” ist schon in Ordnung. Ich verweise einfach mal auf das Android-Hilfe Forum. Dort gibt es die notwendigen Informationen, um CyanogenMod auf dem Huawei Ascend P1 zu installieren.

    Link: http://www.android-hilfe.de/custom-roms-fuer-huawei-ascend-p1/

    Wenn du weitere Fragen dazu hast, dann kannst du sie auch vertrauensvoll in diesem Forum stellen.

  3. Kommentar von Tobias We · · #

    Eine Frage hab ich noch: unzwar hab ich alles gemacht, was in dem forum stand und es hat auch alles einwandfrei funktioniert und die SuperSU ist auch installiert, nur ist jetzt die Frage, ob CWM oder TWRP installiert ist?

  4. Kommentar von Tobias We · · #

    okay hat sich geklärt.

  5. Kommentar von reraiseace · · #

    Freut mich :)Zum einfachen Wechsel des Recovery’s empfehle ich dir die App Recovery Tools.

  6. Kommentar von Tobias We · · #

    ich habe noch eine frage: unzwar habe ich jetzt cyanogenmod installiert und es startet und alles läuft einwandfrei, außer wenn ich supersu starte, dann kommt die meldung, dass ich das binary update(oder so) machen soll. wenn ich das machen möchte kommt eine fehlermeldung. dann gibt es aber auch eine zweite möglichkeit, und zwar über das recovery. wenn ich das mache, startet android nicht mehr und bleibt beim huawei logo hängen… kann man das irgendwie beheben?

  7. Kommentar von reraiseace · · #

    Nimm die aktuellste SuperSU-Version aus meinem Beitrag auf Android-Hilfe (Link). Das Zip-Archiv via CWM oder TWRP installieren. Danach sollte SuperSU nicht mehr maulen. Du kannst dir die App aus dem Play Store nachinstallieren. Dann sollte das Problem in Zukunft nicht mehr auftreten.

  8. Kommentar von Tobias We · · #

    ich hoffe, dass ich dich jetzt nicht mit so vielen fragen nerve, aber meine externe sd karte wird als interne sd karte erkannt?! ist das normal? aber apps werden noch auf der richtigen internen karte gespeichert. hab ich da irgendwas falsch gemacht?

    danke nochmal für alle tipps und tricks :)

  9. Kommentar von reraiseace · · #

    Die Frage kann ich dir jetzt nicht genau beantworten, da ich mir noch kein CM auf meinem P1 installiert habe. Wär aber möglich, dass die externe SD als interner Speicher erkannt wird. Finde ich nebenbei bemerkt auch besser. Denn so viel hat das P1 Intern nicht. Das Apps weiterhin auf dem internen Speicher laden ist korrekt.

    Wenn du auf diese Frage eine konkrete Antwort haben willst, dann wäre es besser im Android-Hilfe Forum direkt im Thema zu fragen.

  10. Kommentar von Tobias We · · #

    ok, dass stimmt mit dem mehr arbeitsplatz. dann werde ich es jetzt so lassen. hätte ich keinen zum fragen gehabt, wie dich, dann hätte ich jetzt kein gerootetes handy mit cm drauf :D danke nochmal dafür :)

  11. Kommentar von reraiseace · · #

    Keine Ursache :)

  12. Kommentar von Roger · · #

    Leider funktioniert die Installation nicht unter der neuen Jelly Bean Beta B336. Das SU-User-Busybox erscheint nicht als App und auch der TWRP warnt vor dem Reboot, dass er der Meinung ist, das Gerät sei nicht gerootet. Es wird sogar angebten, SU-User zu installieren. Aber auch wenn ich hier zustimme, ändert sich nix. Werde wohl mal im Netz nach “Huawei U9200 B336 rooten” suchen müssen.

  13. Kommentar von reraiseace · · #

    Nein, dann wirst du dich nicht genau an die Anleitung gehalten haben. Die B336 lässt sich ebenso rooten, wie alle anderen Firmware-Versionen des P1. Da ich die B336 schon erfolgreich gerootet habe und es andere auch geschafft haben, klappt es mit diser Methode definitiv ;) Versuchs nochmal. Eventuell neuinstallieren und notfalls einen Werksreset mit dem P1 durchführen. Vorher aber alle Daten sichern.

  14. Kommentar von Tobias We · · #

    Ich wollte jetzt wieder mit der ADB arbeiten, die ich auch für das Rooten benötigte, doch wenn ich jetzt alles starte, kommt die Fehlermeldung: error: device not found?! Kann man das irgendwie beheben?

  15. Kommentar von reraiseace · · #

    Schau mal nach, ob das P1 im Fastboot-Modus vom PC erkannt wird. Kann sein, dass die Treiber mit CM10.2 nicht mehr zugeordnet werden können. Ansonsten such nach dem Sooner Single Interface ADB Treiber, wie oben beschrieben.

  16. Kommentar von Tobias We · · #

    Okay :) Fehler gefunden. In CyanogenMod muss man durch 7x auf die Build Nummer in der “Über das Telefon” Einstellung die Entwickler Optionen erst freischalten. Das habe ich dann gemacht und USB-Debugging war auf “Aus” gestellt. Ich hab es wieder angeschaltet und jetzt funktioniert alles problemlos :)

    Danke nochmal :D

  17. Kommentar von reraiseace · · #

    Stimmt, das war auch noch eine mögliche Fehlerquelle.

  18. Kommentar von plings · · #

    Hallo, wenn ich die SuperSU-Busybox-Installer.zip installieren will,
    erscheint in rot “Failed”, weil “E:signature verification failed”.

    Kann mir jemand da helfen?

  19. Kommentar von reraiseace · · #

    Hallo plings,

    ich vermute jetzt einfach mal, du hast versucht das ZIP-Archiv über die Stock Recovery zu flashen. Das kann allerdings nicht funktionieren, da das Archiv nicht signiert ist. Daher bitte meine Anleitung genau lesen und dann klappts auch mit dem Rooten.

  20. Kommentar von jochen · · #

    Hallo
    habe alles artig befolgt, habe ein Huawei Ascend P1 (Build Nr ….B315) Windows 7/64 bit. Bei der USB Verbindung startet die Hi Suite automatisch, ich schließe sie dann manuell. Das Gerät wird erkannt mit beiden SD Karten.

    Bei mir stockt es dann leider schon bei “Blaze”. Nach dem Befehl “adb reboot bootloader” Startet das Ascend neu und es erscheint lediglich ein Huawei Logo auf dem Smartphone. Es wird auch nicht mehr als Laufwerk erkannt. Bei Windows “Geräte und Drucker” ist Blaze unter der Rubrik “nicht angegeben” dargestellt. Kein Warndreieick, aber Treiber sind bei Blaze nicht installiert (Code28). Auch durch den Befehl “Treiber akutalisieren” werden keine Treiber gefunden, weder auf dem PC noch im Netz. Google Suche nach Blaze Treibern hat auch nicht geholfen

    Tja, was nun? Zumindest funktioniert das Ascend nach einem längeren Druck auf die Ein-Taste wieder. Ich mache vermutlich einen Fehler, nur welchen?

  21. Kommentar von reraiseace · · #

    Hallo jochen,

    bitte prüfe, ob USB-Debugging eingeschaltet ist und die Universal ADB Driver korrekt installiert wurden. Das Verhalten ist im Grunde richtig, es scheitert lediglich an der Treiberinstallation. Geh genau nach meiner Beschreibung für die Auswahl des richtigen Treibers vor.

    Sollte das auch nicht klappen, dann probier es mit den Treibern aus meinem Artikel ADB und Fastboot unter Windows XP richtig installieren

  22. Kommentar von roscoe · · #

    Hab auch versucht nach dieser Anleitung die B336 zu rooten. Geht nicht. Das Problem fängt schon damit an, dass Win7(64)bei der Installation der ADB Treiber Probleme macht. Zumindest wenn man nach dieser Anleitung geht. Der Treiber wird standardmäßig so wie im Bild rot markiert installiert und hat auch kein gelbes Ausrufezeichen. Versucht man dann, so wie im Text beschrieben, den Treiber auf den Sooner Treiber zu ändern (warum eigentlich) verweigert Win7 diese Installation mit dem Hinweis auf Inkompatibilität und fehlerhafte Funktion.

    Ich hab dann mit der dann mit dem im Bild rot markierten Treiber weiter gemacht und konnte auch bis zum geladenen TWRP kommen. Die weiteren Schritte wurden dann auch wie schon zuvor beschrieben mit Fehlermeldungen ausgeführt, bzw. vor dem weiteren Vorgenen gewarnt.

    Eine vermutliche Lösung hab ich dann bei den XDA-Leuten gefunden, allerdings aus Zeitmangel noch nicht getestet.

    Hier mal der Originaltext aus diesem Forum:

    with B336 this method doesn’t work.

    EDIT:
    The problem is not in TWRP or CWM; the problem is that there is not enough space in folder /system/app.
    From TWRP I went to “Advanced” and then “file manager”; here from the /system/app I deleted all the languages ​​other than Italian-pack (my language), chrome.apk and gsm-map.apk. Then I flashed SU_flashable and after boot-up SU was finally installed.
    It seems that the difficulty of obtaining root permissions in all stock roms from b105 onwards is precisely linked to the lack of space in the / system / app.
    I hope to be helpful to those who find themselves with the same problem.

  23. Kommentar von reraiseace · · #

    Hallo roscoe,

    das Problem welches du hier beschreibst, kann ich so nicht bestätigen. Die B336 hatte ich selbst im Einsatz und hatte keinerlei Probleme mit dem Rooten. Die Treiberinstallation unter Windows 7 ist etwas frickelig — richtig. Das Aufspielen von SuperSU stellt jedoch kein Problem dar.

  24. Kommentar von roscoe · · #

    So, ich hab mal nach den Hinweisen aus dem XDA-Forum versucht mein P1 zu rooten. Es funktioniert sofort, wenn man im Ordner system/app Platz schafft und einige nicht benötigte apps löscht. Dann ist Rooten eine Sache von zwei Minuten.

  25. Kommentar von reraiseace · · #

    Danke für deinen Kommentar. Dann frage ich mich jetzt nur, wieso es bei einigen ohne Löschen von System Apps geht und bei wiederum nicht. Das ist merwürdig, da die Geräte eigentlich alle gleich sein sollten.

    Edit: Hab deine Problem samt Lösung als Update eingefügt.

  26. Kommentar von pr0xim0 · · #

    Hallo,

    ich habe versucht nach deiner Anleitung zu rooten.

    Alles passt, Debugging Modus, Fastboot, usw.

    Ich komme ins TWRP installiere die Zip-Datei und ab hier weicht dann der Screen von deiner Beschreibung ab. Fix Permission kommt bei mir nicht. Auch lässt sich SuperSU nicht installieren. Zu mindestens taucht es nicht auf Smartphone als APP auf.

    Wenn ich versuche dein Update vom 04.12.2013 umzusetzen, komme ich bis zum Punkt Mount und dann Mount System. Allerdings wird bei mir immer nur die SD Karte gemounted:( Von hier auskomme ich auch nicht in den File manager, da ich vorher immer erst “unmounten” muss.

    Ich weiß nicht mehr weiter.

    Gruß
    pr0xim0

  27. Kommentar von reraiseace · · #

    Welche Firmware hast du denn auf deinem P1?
    Hast du TWRP und SuperSU von hier oder aus einer anderen Quelle?

    Die SuperSU-ZIP flashst du im TWRP über “Install”. Sollte Fix Permissions nicht erscheinen, findest du diesen Button unter “Advanced”. Falls du den System-Ordner mounten willst/musst, gehe im Menü auf “Mount”. Bei “system” das Kreuz setzen. Danach in Advanced->File Manager und dann den Ordner “system” aufrufen.

  28. Kommentar von pr0xim0 · · #

    Hallo das ging ja schnell. Den letzten Satz habe ich eben durch ausprobieren auch umgesetzt. Daran lag es, dass ich einfach nur den Haken setzen musste.
    Sorry. Ist mein erster Versuch mit dem rooten. Nun hat alles geklappt. Zum Thema warum einige P1 SuperSU nicht installieren können (dein Update vom 04.12.13).

    Ich habe in einem anderen Forum gelesen, dass durch die letzten Firmware updates die GPS Log Files nicht mehr gelöscht werden. Ab einem gewissem Alter des Systems bzw. in Abhängigkeit der Nutzungshäufigkeit vom GPS ist irgendwann die System Partition voll.

    Danke dir für die root Anleitung.

    Gruß
    Pr0xim0

  29. Kommentar von reraiseace · · #

    Kein Problem. Wir haben alle mal klein angefangen. Glückwunsch! Du scheinst die B315 auf deinem P1 zu haben. Huawei hat vor wenigen Monaten eine offizielle internationale Version herausgebraucht. Schau mal im Android-Hilfe Forum vorbei. Dort findest du alle Informationen dazu. Damit wird auch der GPS-Log-Bug behoben.

  30. Kommentar von pr0xim0 · · #

    Ja habe B315 drauf. Vielen Dank für den Tipp!

  31. Kommentar von reraiseace · · #

    Ich bin dort der zuständige Senior-Moderator für alle Huawei-Geräte. Also falls du dich dort anmeldest/angemeldet bist und Hilfe brauchst, steh ich dir dort auch gerne zur Verfügung.

  32. Kommentar von Crusty · · #

    Hallo,

    ich habe alles nach Anleitung getan.
    Supersu konnte ich im TWRP ohne Fehlermeldung flashen.
    Permission Fix habe ich manuel über “Advanced” durchgeführt.

    Nach neustart mit einen Root Checker überprüft, aber kein root. Supersu ist als Android App installiert und meldet mir kein Root. Ich habe echt keinen Plan mehr. Bin die Anleitung x mal durchgegangen. Das Update vom 04.12.2013 bin ich auch durchgegangen aber es hilft nichts. Wie gesagt, ich bekomme ja auch keine Fehlermeldung nach der Installation. Alle benutzen Tools habe ich von hier…..

    Das P1 hat folgende Build Nummer..

    U9200-EM-UMTS-V100R00G411D00B336

    Kernel

    3.0.31-dirtyandroid@localhost #1

    Hat jemand eine Idee ?

  33. Kommentar von reraiseace · · #

    Hallo Crusty,

    wahrscheinlich wird das su-Binary nicht installiert sein. Du kannst versuchen es über SuperSU nachträglich zu installieren oder entpack mal die SuperSU-Busybox-Installer.zip. Dann kannst du via TWRP das Binary mittels des File Managers kopieren.

    Sollte dies auch nicht klappen, versuch folgendes: Erstelle ein Backup des System-Ordners, formatiere anschließend genau diesen Ordner und spiel danach das Backup zurück. Manchmal werden die Dateirechte falsch gesetzt.

  34. Kommentar von Crusty · · #

    Hallo reraiseace,

    erstmal sorry das es von mir keine Rückmeldung gab, leider ist unerwarteter weise das Krankenhaus dazwischen gekommen.
    Ich habe mich heute der Sache nochmal angenommen und irgendwie hinbekommen. Ich vermute aber das du mit der su-Binary recht gehabt hast. Hab einige Sachen durchprobiert und kann deshalb nicht sagen woran es genau lag :))). Danke nochmal :)

  35. Kommentar von reraiseace · · #

    Hallo Crusty,

    schön, dass es jetzt bei dir funktioniert hat :-)

  36. Kommentar von Jakob S · · #

    Hey,
    erstmal vielen Dank für den Beitrag! Bei mir ist jetzt nur das Problem, dass es nicht funktioniert.. Ich reboote es, führe TWRP aus, installiere SuperSU/Busybox-zip, mach den permission fix, starte das handy neu, und da ist kein SuperSU, oder sonst was… Habe auch schon viele Apps deinstalliert und immer wieder versucht.. tut nix :/

    weißt du da vielleicht was ?

  37. Kommentar von reraiseace · · #

    Welche Firmware hast du drauf?

    Schau, das du System-Apps entfernst. Wie das geht, steht weiter oben beim Update vom 04.12.2013. Ansonsten sichere mal via TWRP das system, formatiere es anschließend und spiel die Sicherung zurück. Manchmal werden die Rechte nicht richtig gesetzt.

  38. Kommentar von Jakob S · · #

    Es ist die neueste Huawei firmware (android 4.0.3, kernel 3.0.8)
    System-apps sind sowas wie Google+ ?
    Das mit der Sicherung probier ich danach..

    danke schonmal!

  39. Kommentar von reraiseace · · #

    Okay, an der Version liegt’s schon mal nicht. Google+ kann eine System-App sein. Schau besser unter Apps nach, was alles nicht unter Heruntergeladen steht. Google Chrome beispielsweise ist mit relativer Wahrscheinlichkeit eine System-App. Da du sie nachher wieder aus dem Play Store installieren kannst, halb so wild.

  40. Kommentar von Jakob S · · #

    Danke! :)
    Ich mach grad mit TWRP ein Backup, dann schau ich nach den Apps

  41. Kommentar von Jakob S · · #

    So, ich habe jetzt etliche SystemApps deinstalliert, reboot, über TWRP SuperSU installiert usw, immernoch nichts. Ich setz mich da morgen nochmal dran, jetzt is es mir dafür zu spät ;)

    Danke aber schonmal bis jetzt

  42. Kommentar von Jakob S · · #

    I rooted it *____*

    I restored a backup with TWRP and it worked! Thank you a lot!

  43. Kommentar von reraiseace · · #

    Freut mich, das ich helfen konnte.

  44. Kommentar von Hubert · · #

    Hallo,

    bei mir erkennt er “Blaze” nicht. Es steht nur unbekanntes USB Gerät bei “Geräte und Drucker. Ich habe Windows 8.1. Habe den ADB Treiber deinstalliert und wieder neu installiert, komme aber immer zu dem selben Ergebnis. Ich bin genau der Anleitung gefolgt. Wäre nett wenn mir jemand helfen könnte.

    MfG

  45. Kommentar von Hubert · · #

    Ich habe es jetzt hinbekommen. Nachdem ich an 2 PCs (Win 8.1) vergeblich versucht habe das P1 zu rooten, habe ich an einem 3. PC mit Win 7 erfolg gehabt. Der Treiber damit “Blaze” überhaupt erst angezeigt wird, kommt von der HiSuite. Ich kann mir nicht erklären warum das mit Win8 bei mir nicht funktionierte.

    MfG

  46. Kommentar von reraiseace · · #

    Freut mich, das es nun bei dir geklappt hat. Das Setup von ADB und Fastboot ist immer etwas tükisch. Möglicherweise werden entweder die ADB und Fastboot-Treiber oder die des P1 unter Windows 8.1 nicht ordnungsgemäß erkannt.

  47. Kommentar von Ralf · · #

    Guten Morgen und frohe Ostern erst einmal :-)
    Habe das Handy nach den Tipp mit den /system/app dann doch rooten können, unter der Firmware B226 hatte damals alles problemlos funktioniert. Nach diversen Macken wollte ich dann doch auf JB umsteigen und habe mich erneut an diese Anleitung gehalten.

    Diverse Programme bescheinigen mir auch einen Root-Zugriff, Super-SU ist auch installiert, aber ich kann keine Bloatware entfernen, wie z.B. Talk, Facebook und den ganzen Google-Dreck – weil mir angeblich Root fehlt. Habe es mit Root-Uninstall und Root App Delete probiert. Hat einer von Euch einen Tipp? Das wäre super! Denn ich brauche diese Programme nicht und kostet einfach nur Akkulaufzeit und unnötig viel Ram. Ach ja und besten Dank für diese klasse Anleitung!

    LG,
    Ralf

  48. Kommentar von reraiseace · · #

    Frohe Ostern. Geh mal bitte ins TWRP und sichere dort die System-Partition, anschließend formatierst du System und spielst dein Backup wieder zurück. Manchmal werden die Rechte beim Flashen nicht korrekt gesetzt. Damit kannst du das beheben.

    Solltest du die Programme nicht via Apps entfernen können, kannst du sie direkt im Recovery löschen. TWRP hat einen eingebauten Dateimanager, damit klappt das auch.

  49. Kommentar von Ralf · · #

    Vielen Dank für die schnelle Antwort. Habe ein Backup gemacht im TWRP und dann über Wipe -> System gelöscht (ich hoffe das war richtig) und dann das Backup wieder eingespielt. Leider ohne Erfolg. Erstaunlicherweise sehe ich nach dem mounten unter system/apps Facebook, Twitter und co. gar nicht mehr und sie sind trotzdem auf dem Smartphone…Hab ich was falsch gemacht bzw. habt ihr noch einen Tipp?
    LG!

  50. Kommentar von Michael · · #

    Hallo,

    um mein P1 zu rooten, häng ich wohl am gleichen Problem, doch
    wie schafft man unter “system/app” Platz? Ich kann dort leider nichts löschen. ( keine Rechte) ?

  51. Kommentar von reraiseace · · #

    Hallo Michael,
    welche Firmware verwendest du? Die Rechte hast du normalerweise. Halte dich an das Update des Artikels und falls das nicht klappt an dieses Kommentar hier.

  52. Kommentar von Michael · · #

    Hallo, danke für die schnelle Antwort. Ich habe gestern auf die 336 geupdated. Leider habe ich jetzt keine root rechte mehr. Aus den obigen Anleitungen sollte ich jetzt Platz schaffen. Ich habe leider keine Ahnung wie ich TWRP starten kann und in dessen Menü komme. Gibts da ne eine leicht verständliche Anleitung ? Dankeschön

  53. Kommentar von reraiseace · · #

    Schalte den Schnellstart aus und danach fährst du dein P1 herunter. Dann über die Tastenkombination Lauter + Power so lange gedrückt halte, bis du ins Recovery kommst, allerdings nur, falls du es bereits geflashed hast. Den anderen Weg kannst du sonst über die Anleitung von oben gehen. Dazu brauchst du aber einen PC.

  54. Kommentar von Michael · · #

    Hallo reraiseace,
    nun sitzt ich am PC und kann dir die Lage etwas detailierter erklären. Sorry, war vorher immer ziemlich kurz angebunden.

    Ich hatte bis vor 3 Tagen die B315 inkl. root auf meinem P1.

    Ich habe übers Menü und SD Karte nun auf die B336 geupdatet, und dabei ging meine root verloren, den ich nun wieder haben möchte

    Ich habe deine Anleitung oben befolgt bis zum Punkt 2 Treiber aktualisieren => versucht an 3 versch. Win 7 PC´s
    (32 u. 64bit) Leider lassen sich die Treiber nicht so installieren wie beschreiben.

    Daher bin ich ziemlich sicher dass ich auch wie beschrieben einige .apks aus system/apps auf dem smartphone löschen muss.

    Und da weiß ich nicht weiter….
    mit Power + Lauter erscheint bei mir das “Android system rocovery utility” mit 5 auswahlpunkten, jedoch leider keinem file explorer mit den nötigen rechten im genannten verzeichnis etwas zu löschen.

  55. Kommentar von reraiseace · · #

    Okay. Du hängst bei der Treiber-Installation fest. Da musst du keine Apps von deinem Smartphone löschen, weil das zum aktuellen Zeitpunkt gar nicht funktioniert. Du kommst noch nicht mal in ins TWRP.

    Das Problem, welches du hast, ist bei deinem PC zu suchen. Erkennt der Computer das Gerät als Blaze? Falls dem so ist, installier bitte die ADB Treiber neu. Falls das nicht so ist, dann bitte die HiSuite erneut installieren und nach obiger Anleitung die Geräte-Treiber installieren.

  56. Kommentar von Michael · · #

    Morgen reraiseace und schönen 1sten Mai.

    Ja der Computer erkennt es als Blaze, doch leider keine Chance die Treiber wie oben beschrieben auszuwählen.
    Ich habe daher parallel das ganze an meinem Laptop zusätzlich nochmals probiert, leider mit dem selben Ergebniss.
    Treiber und HiSuite gerade nochmals neu installiert und erneut Probiert => hab hier mal einen Screenshot gemacht
    https://dl.dropboxusercontent.com/u/36110225/Unbenannt.JPG

    und genau an der Stelle hänge ich.

  57. Kommentar von Michael · · #

    Hi, ich nochmal. Vergiss meinen vorigen Post. Habe es nun endlich hinbekommen, dank eines Hinweises aus einem anderen Forum.
    Trotz Win 7, musste manuell den Treiber angeben
    Ähnlihc wie 3ter Post in diesem Forum
    http://www.android-hilfe.de/root-custom-roms-modding-fuer-huawei-ascend-p1/420754-how-root-huawei-p1-android-4-1-1-build-b315-7.html

    Naja nun hat es endlich geklappt, jetzt vlt. mal Cyanogenmod testen… Danke für die deine Mühe Gruß

  58. Kommentar von reraiseace · · #

    Hallo und ebenfalls einen schönen 1. Mai. Freut mich, dass es nun geklappt hat. Die Verbindung mit Blaze herzustellen ist der schwierigste Schritt. Danach ist eigentlich alles andere ganz einfach. Bei Android-Hilfe findest du auch zu CyanogenMod reichlich Hilfestellung.

  59. Kommentar von Jannis Dahler · · #

    Ich habe alles gemacht, wie es in der Anleitung steht, aber beim Recovery flashen kommt nur “? fastboot” wenn ich “fastboot devices” eingebe und “cannot load recovery.img”, wenn ich “fastboot flash recovery recovery.img” eingebe. Unter “Geräte und Drucker” wird “Blaze” korrekt angezeigt. Wäre schön, wenn mir jemand helfen könnte.

  60. Kommentar von reraiseace · · #

    “? fastboot” sollte stimmen. Stell bitte sicher, dass die recovery.img im selben Ordner mit der fastboot.exe ist und auch so benannt wurde. Sollte das der Fall sein und es geht trotzdem nicht, lade das Recovery bitte neu herunter. Möglicherweise war der Download unvollständig.

  61. Kommentar von Jannis Dahler · · #

    Erst mal danke für die schnelle Antwort, aber es war viel einfacher. Ich habe einfach an “fastboot flash recovery recovery.img” noch ein “.img” angehängt. Der eigentliche Befehle lautet also “fastboot flash recovery recovery.img.img”.

  62. Kommentar von reraiseace · · #

    Kein Ding. Dann war das Recovery einfach nur komisch benannt.